The browser does not support javascript.
LANDFIRE - multi-partner wildland fire, ecosystem, and wildland fuel mapping projectGraphics for LANDFIRE
[Skip to Content]

YouTube Twitter LANDFIRE HELP
Homepage » Browser Requirements


 

Browser Requirements

Older browsers will not have access to landfire.gov due to security upgrades.
Browser requirements for www.landfire.gov are:

BrowserVersion Requirements
Chrome30-32 or higher
Android5.0.2
Mozilla Fire Fox27-33, ESR 31.0-31.2
Internet Explorer11
Windows mobile8.1
Opera17-19
Apple-SafariOSx10.9
Apple-mobileIOS 5,6